Introduction to NI Multisim and NI Ultiboard

Elias Nicolas
Applications Engineer
National Instruments
Today, We’ll Explore:

<table>
<thead>
<tr>
<th>Lesson 1</th>
<th>Introduction to NI Multisim</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>What is Multisim?</td>
</tr>
<tr>
<td></td>
<td>Components Database</td>
</tr>
<tr>
<td></td>
<td>Drawing schematics</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Lesson 2</th>
<th>Simulation and Virtual Instruments</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Simulation settings</td>
</tr>
<tr>
<td></td>
<td>Using virtual instruments</td>
</tr>
<tr>
<td></td>
<td>Circuit Wizards</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Lesson 3</th>
<th>Educational Features</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Component Faults</td>
</tr>
<tr>
<td></td>
<td>Ladder Diagrams</td>
</tr>
<tr>
<td></td>
<td>3D ELVIS Virtual Breadboard</td>
</tr>
<tr>
<td></td>
<td>Analysis in Multisim</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Lesson 4</th>
<th>Ultiboard Basics</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Transfer to PCB layout</td>
</tr>
<tr>
<td></td>
<td>Ultiboard GUI</td>
</tr>
</tbody>
</table>
Lesson 1: Introduction to NI Multisim

• What is Multisim?
• Workspace Area
• Components Database
• Drawing schematics
What is Multisim?

- General purpose EDA tool
- Schematic Capture
- Simulation
- Analyses
- Integrated Environment
Benefits of Integrated Capture & Simulation

- Preparation for simulation is as simple as drawing a circuit
- Interactive Simulation
- Animated Parts
- Virtual Instruments
- Analyses and Graphs

Effective use of your time!
The Multisim GUI

- Organized menus
- Quick access toolbars
- Design Toolbox
- Spreadsheet View
- Resizable Workspace
Toolbars and Menus

- Organized based in functionality
- All toolbar functions found in menus
- Right-click toolbar area and toggle toolbars
- Customizable (functions, location)
Design Toolbox

View » Design Toolbox

- Manage various elements in the schematic design
- Great tool for medium- and large-complexity designs
- Control visibility of annotation layers
- Access to the Project View
Spreadsheet View

• Advanced parameter viewing and editing
• Global perspective of objects and properties
• Find and select components
• Modify component or net properties
• Review ERC, Simulation and other results

Tip: You can modify properties for multiple components or nets at once if you use the <SHIFT> or <CTRL> keys for multiple selection.
Workspace Area

- Schematic area
- Multiple tabs
- Zoom in and out with the mouse wheel (default)
- Use **View** menu to show/hide Grid and Page Border
Schematic Capture

- Multisim offers click-and-place capture mode
- Integrated with simulation

• Three step process:

  - Select
    - Component Database
    - In-Use List
    - Copy
    - Replace

  - Place
    - Rotate
    - Flip
    - Multi-section

  - Wire
    - Automatic
    - Touching-pins
    - Dropping
Components

- Symbolic representation of actual parts
- All components have a symbol
- Many components have a SPICE model and footprint

Capture Area
- Symbol

Simulation Engine
- SPICE Model

PCB Layout
- Footprint
## Components – Virtual, Real, Layout-only

<table>
<thead>
<tr>
<th>Component</th>
<th>Symbol</th>
<th>Model</th>
<th>Footprint</th>
<th>Default Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Virtual</td>
<td>✓</td>
<td>✓</td>
<td>✗</td>
<td>(black)</td>
</tr>
<tr>
<td>(simulation only)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Real</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>(blue)</td>
</tr>
<tr>
<td>(simulation and layout)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Layout-only</td>
<td>✓</td>
<td>✗</td>
<td>✓</td>
<td>(green)</td>
</tr>
<tr>
<td>(layout only)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Component Database

Tools » Database » Database Manager

Three levels:

- Master Database
- Corporate Database
- User Database

Parts bin up to 17,500 parts (Power Pro edition)
Master database cannot be edited
Database utilities let you merge other user’s database, or convert a database from a previous version
Component Database

• Corporate database
  • Share components with colleagues
  • Located in local disk or network drive

• User database
  • Store your own custom components

• If you modify a Master database component, save it into the Corporate or the User database.

Caution: Always backup your Corporate or User database.
Component Browser

- **Place Component**
- Most common tool to place components.
- You can select:
  - Database
  - Component
  - Model
  - Footprint
  - Search for components

**Tip:** Right-click anywhere in the workspace and select **Place Component** to access the Component Browser.
To place a part, select:
1. Database
2. Group
3. Family
4. Part
5. Model
6. Footprint

You can also:
• Search
• Obtain datasheet
• Print a detail report
• View model
Placing a Component

- After selecting a component, a ghost image is attached to the mouse pointer
- Click to place
- Next RefDes is assigned
Component Toolbar and the In-Use List

- Access Master database **Groups** from the **Components** toolbar.

- Use the **In-Use List** to place another instance of an already placed component.
Rotating a Component

- If already placed
- While placing

While dragging the component... Press <Ctrl+R>... Then click to place.
Nets

- Wires are the graphical representation of nets
- Modeless (no placing vs. wiring mode)
- Mid-air wiring is allowed
- Real-time netlist is updated behind the scenes
- Easy to change wire connections once placed
Nets

- Multiple wires can make one net or node

This is a single-wire net. Netname is VSneg.

This is a multi-wire (6) net. Netname is 0.
Junction Dots

Junction dots represent a wire connection
Methods for Wiring – Automatic

1. Click start pin of the first component.

2. A wire will be attached to the crosshair cursor.

3. Click the destination pin on the second component.

4. A wire will connect the components.
Methods for Wiring – Touching Pins

1. Select the component to wire. Notice red dot.

2. Move component and touch pins to be wired.

3. Drop the component. Connection is made.

4. Drag the component away.

5. Drop the component. Wire is ready.
Methods for Wiring – Dropping

1. Select component to wire.

2. Move the component and place it over the wire to be connected in series.

3. Drop the component. The connection is made.
Changing Wire Properties

- Right-click the wire to access the run-time menu
- Change colors, net name font and properties
Exercise 1: Schematic Capture

- Build and wire a filter circuit
- Search for components
- Move and rotate components
Lesson 2: Simulation and Virtual Instruments

• Simulation settings
• Using virtual instruments
• Measurement Probe
• Circuit Wizards
Multisim Treats Simulation Differently

- Most users are not experts in simulation
- User wants the benefit of simulation without having to know the details of SPICE
- Netlist is hidden from the main schematic, visible through the SPICE Netlist Viewer
- If you want to use advanced SPICE syntax you can, using the Arbitrary SPICE Block or the XSPICE Command Line
Multiple Models Available

- Some components offer more than one model
- Higher level models simulate more sophisticated or unique effects of the component’s behavior
Observing a Circuit Simulation

- Start/Pause/Stop functions
- Animated parts
- Virtual Instruments
- Analyses and Graphs
Simulation with Real-world Signals

- Integrating NI measurement & automation products into the design stage allows real-world stimuli to be used

![Flowchart diagram showing the cycle of Design/Simulate, Real-World I/O Integration, Prototype, Industry-Relevant Integration, and Deploy.]
Virtual Instruments

- Select instruments from the **Instruments** toolbar

<table>
<thead>
<tr>
<th>Instrument Type</th>
<th>Instrument Name</th>
<th>Additional Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multimeter</td>
<td>Word Generator</td>
<td>Agilent Function Generator</td>
</tr>
<tr>
<td>Function Generator</td>
<td>Logic Analyzer</td>
<td>Agilent Multimeter</td>
</tr>
<tr>
<td>Wattmeter</td>
<td>Logic Converter</td>
<td>Agilent Oscilloscope</td>
</tr>
<tr>
<td>2-ch Oscilloscope</td>
<td>IV-Analysis</td>
<td>Tektronix Oscilloscope</td>
</tr>
<tr>
<td>4-ch Oscilloscope</td>
<td>Distortion Analyzer</td>
<td>Measurement Probe</td>
</tr>
<tr>
<td>Bode Plotter</td>
<td>Spectrum Analyzer</td>
<td>LabVIEW Instrument</td>
</tr>
<tr>
<td>Frequency Counter</td>
<td>Network Analyzer</td>
<td>ELVISmx Instruments*</td>
</tr>
</tbody>
</table>

* When the ELVISmx driver is installed.
Virtual Instruments – Front Panel

- Double-click instrument icon to open front panel
- Set instrument settings just like a real instrument
Using Instruments in Circuits

- Place instruments like any other object
- Wire the instrument to the circuit
- Configure instrument settings
Measurement Probe

- Constantly updated values
- Fast, simple alternative to instruments
- Save space in the schematic
- Configurable, Trigger events (conditional probe)
- Dynamic or static probes available
Exercise 2: Simulating Circuits

- Examine the response of the bandpass filter
- Change the response of the circuit by interacting with the components
- Learn how to use various instruments
- Save simulation results for comparison
Coffee Break
Enjoy Coffee and Networking With Peers
Lesson 3: Educational Features

- Component Faults
- Ladder Diagrams
- Circuit Description Box
- Circuit Restrictions
- 3D ELVIS Virtual Breadboard
Component Faults

- Access through the **Fault** tab in the component’s properties window
- Use to simulate faults on components
  - Open
  - Short
  - Leakage
Rated Virtual

- Multisim includes *rated virtual* components
  - Virtual components
  - They “blow” if pre-set tolerance is exceeded at simulation
  - Tolerance is set in the value tab of the properties dialog
Global and Circuit Restrictions

- Hide component faults to force students to find the fault using virtual instruments
- Disable access to features that you do not want students to have
- Lock subcircuits to create a “black-box” circuit which students need to analyze
- Password protect
Ladder Diagrams

- Create interactive ladder diagram logic
- Use PLC-like components
3D Breadboard

- Place components in 3D on a virtual breadboard
- Practice wiring a breadboard based on a circuit diagram
- Component symbols and wires turn green when placed correctly on breadboard
3D ELVIS Breadboard

- File » New » NI ELVIS I Design ... Or NI ELVIS II Design
- Interact with NI ELVIS instruments
- Place and verify diagram similar as the virtual breadboard
Demonstration on 3D Visualisation
### Analyses in Multisim

- The following analyses are available:

<table>
<thead>
<tr>
<th>Analysis</th>
<th>Analysis</th>
<th>Analysis</th>
</tr>
</thead>
<tbody>
<tr>
<td>DC Operating Point</td>
<td>Distortion Analysis</td>
<td>Transfer Function</td>
</tr>
<tr>
<td>AC Analysis</td>
<td>DC Sweep</td>
<td>Worst Case</td>
</tr>
<tr>
<td>Single Frequency AC Analysis</td>
<td>Sensitivity</td>
<td>Monte Carlo</td>
</tr>
<tr>
<td>Transient Analysis</td>
<td>Parameter Sweep</td>
<td>Trace Width Analysis</td>
</tr>
<tr>
<td>Fourier Analysis</td>
<td>Temperature Sweep</td>
<td>Batched Analysis</td>
</tr>
<tr>
<td>Noise Analysis</td>
<td>Pole Zero</td>
<td>User Defined Analysis</td>
</tr>
</tbody>
</table>

ni.com
Using Analyses

- **Simulate»Analyses»...**
- Four step process:

Select analysis  
Enter expressions  
Select output variables  
Configure analysis parameters and options

**Tip:** Click Help on any window to access analysis-specific information.
Selecting Output Variables

- Choose output variables from the list
- Voltages and currents per node (net) are listed as well as current and power per component
- Add model or device parameters
  - Resistance
  - Capacitance, and so on
- Add expressions
Adding Custom Expressions

• Double-click variable or operand to add it to the expression
• Type expression manually
• Use built-in functions to help create custom analysis outputs
The Grapher

- Displays simulation results from:
  - Virtual Instruments
  - Analyses
- View, adjust, save, print export data
- Precise cursor measurements
- Overlay different results to compare
- Make annotations and place data labels
The Grapher – Overlay Traces

- Compare different graphs
The Grapher – Properties

- Set custom properties for pages and graphs
- Modify the appearance of traces and axes
Exercise 3: Working With Analyses

- Use analyses to explore Bandpass characteristics.
- Configure analyses
- Use the Grapher to visualize results
Introduction

- Ultiboard
- Design Flow
- Ultiboard GUI
- Environment Preferences
What is Ultiboard?

- PCB Layout software
- Integrated Platform with NI Multisim
  - Transfer
  - Forward and Back Annotation
- Autoplacer and Autorouter
- Industry-standard file export
- Gerber Viewer and board 3D View
The Design Process

Where does Ultiboard fit in the design flow?
Benefits of Integrated Platform

- Directly transfer designs from Multisim to Ultiboard
- Keep designs up-to-date with forward and back annotation
- Find a component in the Multisim schematic and vice versa
Transfer from Multisim

- In Multisim, select **Transfer » Transfer to Ultiboard 12.0**
- Virtual Components and non-active variants are not transferred
- Ultiboard prompts for default track width and clearances
- Import Netlist Actions are displayed
Transfer from Multisim – Virtual Components

- In Multisim, you may receive a message warning you about virtual components in your schematic.

![Multisim warning message]

In most cases, this refers to power supplies and ground references. Make sure your board is correctly prepared for transfer.
Transfer from Multisim – Virtual Components

- Generate a Bill of Materials Report
  - Reports ➔ Bill of Materials
  - Click Show Virtual Components
- Review components marked as virtual
- If actual parts are marked virtual, go back to the schematic and assign footprints to them.
Transfer from Multisim – Virtual Components

- It is a good practice to place connectors for power supplies and ground references.
Board Technology

- **Options»PCB Properties**
  - Click the **Copper Layers** tab
  - Set number of layers
  - Layer pairs
  - Via Support
  - Board clearance
  - You can save the current technology for later use
  - **File»Save Technology**
Board Outline

• Default outline is placed after trans
• Create a new outline:
  • Manually
    o Set Board Outline layer active
    o Delete current outline
    o Draw a new one
    o Any shape
  • Board Wizard
    o Rectangular and circular
  • Import DXF
    o Any shape
Part Placement

• Methods:
  • Manual Placement
    o Drag and place Workspace area components
    o Drag and place Spreadsheet View components
  • Part Sequencer
  • Autoplacer

• If you need to add parts, select **Place»From Database**
The Component Wizard

- Takes you through the process of creating a new component
- Only supports IC-like packages
- Save new component to Corporate or User database
- Seven-step process
- Dimensions can be found in datasheets
The Component Wizard  Step 1

- Step 1: Select Technology
- THT
- SMT
The Component Wizard

Step 2

- **Step 2: Package Type**
  - Select from available package types
  - Preview available
  - If the package you are looking for is not available, select next closest
  - You can always edit a footprint at a later time
Step 3: Package Dimensions

- Reference the component’s datasheet
The Component Wizard

Step 4

- **Step 4: 3D Color Settings**
  - Change 3D environment colors
The Component Wizard  

Step 5

- Step 5: Pad Type and Dimensions
  - Use dimensional drawings or set depending on a design requirement
Step 6: Pins

- Specify number of pins and distance between centers
The Component Wizard  Step 7

- **Step 7: Pad Numbering**
  - Set pad numbering and direction
The Component Wizard

- **File ▶ Save to Database**
  - Save to Corporate or User database
  - Add attributes or make any pending modification
Manual Routing

- This option provides complete control of the trace position
- Click **Start Pad**
- Move mouse to create trace
- Click to set a vertex (turn)
- Click **End Pad**
- End pad has a crosshair mark to identify it
Autorouter

• Advanced routing algorithms
• Lock nets already placed
• Configure routing layers
• Autoroute
  Start/resume Autorouter
• Review Results tab in the Spreadsheet View
Autorouter Tips

• If Autorouter is not able to route 100% of the board:
  • Modify Autorouter options
  • Increase number of vias permitted
  • Decrease clearances
  • Decrease trace width
  • Increase number of layers
  • Add jumpers
    o Place►Jumper

• After Autorouter is done, review traces and make any necessary change in geometry or position.
Bill of Materials

- BOM helpful for manufacturing and planning
Print

- **File ➔ Print**
- **Useful for:**
  - Documenting
  - Printer-based PCB processes
- Creating negative images and reflections
3D View

- You can review your finished design in 3D
- Great for documents or presentations
- Use mouse buttons and wheel to:
  - Move
  - Pan
  - Zoom
- View » 3D preview
Exercise 4: Materials Report and Transferring to NI Ultiboard

- Generate and Customize Bill of Materials (BOM) report
- Export BOM report to common text files
- Transfer a completed design to Ultiboard
NI LabVIEW Certifications

On 16th May, FREE Certified LabVIEW Associate Developer!
Thank you!